久しぶりにEmacsビルドしている

* Emacs 27.1が使いたい
* Pop_OS!で普通にインストールしようと思うとflatpak版しかない
* flatpak版Emacsの中からlsp使うと、バイナリがGLIBが違うとか言ってlsp serverバイナリが起動できないことがある

数年前まではEmacsはたいてい自前ビルド使ってて、わりと時間かかるからコーヒーでも淹れるか、という感覚でいたんだけど、今どきのCPUでSSDなマシンでビルドすると速いな!

Follow

flatpakの仕組みわかってないのだが、普通に実行できるバイナリをflatpakのEmacsから実行するとglibcのバージョン違いとか出るのなんでなの

Sign in to participate in the conversation
sandbox : skoji

The social network of the future: No ads, no corporate surveillance, ethical design, and decentralization! Own your data with Mastodon!