Satoshi Kojima
Follow

「libstdc++.so.6: version `GLIBCXX_3.4.20' not found」とか出るやつ、あれどういうことなのかよくわかってない。ABI policy guidelineをみると、3.4.19な奴でもABI的な互換性はありそうに見える。何を守っているの?

なので-fabi-versionを指定してビルドしてもこの問題には効き目はない。「GCCのバージョンを4.8にしてビルドする」くらいしか方法がなくて釈然としない。

(普通にgcc5でビルドするとRHEL7とかCentOS7とかのEL7系で動かないバイナリができてしまう)

EL7系はサポートしません、とは言えなくてそれはRHEL7使っている既存のお客さんがいるから。EL7系は珍しくないし…Amazon Linux 2とか…

Sign in to participate in the conversation
sandbox : skoji

小嶋智@skoji)の個人インスタンスです。/ A single user instance feeds only Satoshi Kojima(@skoji)'s status.